Generic Issues
Incident Report for Smarkets
Resolved
This incident has been resolved.
Posted Mar 09, 2024 - 15:15 GMT
Investigating
We are experiencing some technical difficulties at the moment. This is affecting viewing active bets and payment functions. Placing bets function is still working. Our teams are working on solving the issue. Apologies for the inconvenience caused.
Posted Mar 09, 2024 - 11:31 GMT
This incident affected: Exchange and SBK.