Bet Placement Issues
Incident Report for Smarkets
Resolved
This incident has been resolved.
Posted Feb 11, 2024 - 15:44 GMT
Investigating
We are currently experiencing issues which are affecting the placement of bet builders and accumulator bets. Our teams are working to resolve it as soon as possible.
Posted Feb 11, 2024 - 14:07 GMT
This incident affected: Exchange and SBK.