Pricing Issues
Incident Report for Smarkets
Resolved
This incident has been resolved.
Posted Mar 19, 2024 - 12:34 GMT
Investigating
Unfortunately, we're experiencing some pricing issues at the moment. We are working on resolving this as soon as possible. Apologies for the inconvenience caused.
Posted Mar 19, 2024 - 12:23 GMT
This incident affected: SBK.