Bet Placement Issues
Incident Report for Smarkets
Resolved
This incident has been resolved.
Posted Nov 26, 2024 - 21:56 GMT
Investigating
Apologies, we are currently experiencing issues which are affecting the placement of bets. Our teams are working to resolve it as soon as possible.
Posted Nov 26, 2024 - 10:25 GMT
This incident affected: Exchange and SBK.