Site issues
Incident Report for Smarkets
Resolved
This incident has been resolved.
Posted Apr 14, 2023 - 15:31 BST
Investigating
Technical issues: We are aware of an ongoing issue affecting bet placement. Our engineers are working to fix ASAP!
Posted Apr 14, 2023 - 15:00 BST
This incident affected: Exchange and SBK.