Pricing issues
Incident Report for Smarkets
Resolved
This incident has been resolved.
Posted Aug 12, 2022 - 14:26 BST
Investigating
Unfortunately, we're experiencing some pricing issues at the moment which might affect your betting. Apologies for the inconvenience caused.
Posted Aug 12, 2022 - 12:46 BST
This incident affected: Exchange and SBK.