Bet Settlement
Incident Report for Smarkets
Resolved
This incident has been resolved.
Posted Mar 28, 2024 - 21:55 GMT
Update
We are continuing to investigate this issue.
Posted Mar 28, 2024 - 21:55 GMT
Investigating
We are currently experiencing some technical issues which may affect bet settlement. The team are working on resolving this as soon as possible
Posted Mar 28, 2024 - 19:30 GMT
This incident affected: Exchange and SBK.