Card deposits unavailable

Incident Report for Smarkets

Resolved

This incident has been resolved.
Posted May 03, 2026 - 15:57 BST

Update

We’re currently experiencing issues with card deposits. For a faster and more reliable experience, please use Pay by Bank or PayPal.
We’re working to resolve this as quickly as possible.
Posted May 03, 2026 - 15:01 BST

Update

We’re currently experiencing issues with card deposits. For a faster and more reliable experience, please use Open Banking or PayPal.
We’re working to resolve this as quickly as possible.
Posted May 03, 2026 - 14:22 BST

Investigating

We’re currently experiencing issues with card deposits. For a faster and more reliable experience, please use Open Banking or PayPal.
We’re working to resolve this as quickly as possible.
Posted May 03, 2026 - 14:17 BST
This incident affected: Exchange and SBK.