Pricing Issues

Incident Report for Smarkets

Resolved

This incident has been resolved.
Posted Mar 07, 2026 - 16:03 GMT

Update

Some pricing problems may currently affect your ability to place bets. We’re working to fix this and apologize for the inconvenience.
Posted Mar 07, 2026 - 15:47 GMT

Investigating

Some pricing problems may currently affect your ability to place bets. We’re working to fix this and apologise for the inconvenience.
Posted Mar 07, 2026 - 15:46 GMT
This incident affected: SBK.