Delayed Settlements

Incident Report for Smarkets

Resolved

This incident has been resolved.
Posted Oct 17, 2025 - 12:35 BST

Update

We are continuing to monitor for any further issues.
Posted Oct 17, 2025 - 12:17 BST

Monitoring

We are experiencing some technical issues with delayed settlements.
This is being looked into and will be resolved as soon as possible.
Posted Oct 17, 2025 - 12:17 BST
This incident affected: Exchange and SBK.