Pricing Issues
Incident Report for Smarkets
Resolved
This incident has been resolved.
Posted Aug 21, 2023 - 13:36 BST
Investigating
We're experiencing some pricing issues at the moment which might make it harder for you to bet and are working to resolve these issues as soon as possible. Apologies for the inconvenience caused.
Posted Aug 21, 2023 - 11:46 BST
This incident affected: Exchange and SBK.