Log in Issues
Incident Report for Smarkets
Resolved
This incident has been resolved.
Posted Feb 27, 2024 - 09:10 GMT
Investigating
We are experiencing some technical issues which may affect your ability to login. The team are working on resolving this as soon as possible.
Posted Feb 27, 2024 - 09:09 GMT
This incident affected: Exchange and SBK.