Multiples issue

Incident Report for Smarkets

Resolved

This incident has been resolved.
Posted Oct 18, 2025 - 16:15 BST

Investigating

We are currently experiencing some issues with our services, apologies for the inconvenience.
Our team is working to resolve this as soon as possible.
Posted Oct 18, 2025 - 15:09 BST
This incident affected: Exchange and SBK.